Excel Intermediate-Microsoft Excel 2010

Workshop Objectives
1. Import data: csv files and pasting from 4.
the internet 5.
2. Data manipulation 6.
3. Sorting 7.

1. Importing Data into Excel

Advanced sorting
Filtering
Find duplicate records

If/Else Examples (Find unique records)

You can bring data into Excel that was saved in various file formats from other applications. As excel
is great at crunching numbers and creating graphical representations, importing data can allow for

extending capabilities beyond what the source program had.

. . . Text Import Wizard - Step 1 of 3 7| & |
Exercise 1. Importing a .csv file - — R -~
- e Text Wizard has determined that your data is Delimited,
1' SeIeCt Data rlbbon > Get EXternal If this is correct, choose MNext, or choose the data type that best describes your data.
Data group > From Text SomiEEins
Choose the file type that best describes your data:
2. BI‘OWSE for the dESII’ed flle and CIle @ Delimited - Characters such as commas or tabs separate each field.
_| Fixed width - Fields are aligned in columns with spaces between each field.
Import (Excel data for import.txt)
. L . A Startimport at row: |1 = File origin: 437 : OEM United States IZ|
3. Verify Delimited is selected and click
Next
Preview of file C:\Users\kbright\Desktop\Excel Intermediate Workshop 2013\Excel data example. bet.
4' Verlfy that the Dellmlter IS Set On 1 ["fullname""Term""Current Status""shortname""category""summary™"Facu -
Z ["EDUC-210-01""13/5E"" DUC-210-01""EDUC""HUMAN DEVELOPMENT & LEARN
Tab and click Next 2 |"EDUC-210-027"13/5E"" DUC-210-02""EDUCT"HUMAN DEVELOPMENT & LEARN
4 ["EDUC-210H-01""13/5E" EDUC-210H-01""EDUC""HUMAN DEV & LEARN-HONOR
5. This step allows you to go thrOUgh :; EOUC-210H-02""13/5E [: EDUC-210H-02" "EDUCT"HUMAN DEV & LEARN-HONOR : =
your columns and select the data vt ] [
format
** (select Text for columns of numbers that begin with zero)
6. CIICk FInISh a‘nd OK < h1=Javascript is currently disabled. Javascript is required for WebAdvisor fund
E-mail Phone Acade
: : Stude \, ACCeS ,4dre Numb Class mic Stat
Pasting Data from my.sbu or WebAdvisor - nt . o Lovil
Example 1
. . 10@bona
1. Select all the data that you will be copying M. R SENIORREC
2. click paste - don’t click in the spreadsheet edu I
3. in the bottom right-hand corner look for the : " =
Clipboard B 1@bonay (Ctrl)~ | o
. . . enture.e |
4. Click on the clipboard and select “Match i

destination formatting”
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2. Time Saving Ways to Manipulate Data

Many times the data that you get from other sources is not in the format that you need it to be. In this

section we will look at some easy ways to manipulate the date to the way you want it.

Exercise 2: Text to Columns

. =
1. Click on the Sales Data 2003-05 spreadsheet
2. Click in cell C1 and Insert 2 columns Text to
. . Columns
3. Title the new column, First Name and Change Salesperson to Last Name
4. Click on “B” in the Header Row to select the entire column
5. Click on the Data tab and Text to Columns l
6. The Text to Columns wizard opens up -- on the first screen make sure ;’alesp&rm"
uchanan, James
Delimited is selected and click Next Suyama, Alex
Peacock, Joy

7. Check the box next to Comma (look at the preview pane and notice how the
text is separated) and click Next
8. On the last screen you can choose a format for your columns if you wish — Click Finish

You now have the first and last names in separate columns — this is a great tool if you import data and it

doesn’t import in columns.

@

Exercise 3: Find and Replace

re Format Sort & [Find &
+ | &7 Filter~ [Select
1. Using the Sales Data 2003-05 spreadsheet, click on Find & 8 Find..
Select and then Replace. —
2. Type 2003 in the Find what: text box “ac Replace..
3. Type 2013 in the Replace with: text box = GoTo..
4. Click the Replace or Replace All Go To Special...
5. You should get a dialog box telling you how many items
were replaced Formulas
6. Click OK Comments

'l e R N
Replace

Find what: 2003

Replace with: | 2013

=]
=]

Replace Al | | Repiace | | FindAl | | FndMNext | | Close |
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Exercise 4: Concatenate

Occasionally rather than have the data separated as we did above you need put together in the same

column. For this demo we will create a column with the last name, first name or first salesperson will

then be shown as Buchanan, James.

1. Onthe Sales data 2003-05 spreadsheet, add another column to the right of the first name.

2. Put your cursor in cell D1 to make it the active cell.

3. Click on the Formulas Tab, from the “Function Library” group click on Text and then

o I T T b 27, BT T

Concatenate.

Function Arguments

4. You will get the dialog box shown below,

CONCATENATE
with your cursor blinking in the “Text1” Textl g2 5| = “Buchanan
field. Text2 |*," = = =
5. Click in cell B2 Tex3 [c2 8] - “sames”
Textd | =
6. Move your cursor to “Text2” type a comma
and add a blank space - “Buchanan, James®
7. Move your cursor to the “Text3” field and Joins several text strings into one text string.

click in cell C2

8. Your “Function Arguments” dialog box

Text3d: textl textZ,... are 1to 255 text strings to be joined in
and can be text strings, numbers, or single-cell referery

should look like this _ Formula result = Buchanan, James

9. Click the OK to enter the formula into the Help on ths funchion

[

cell.

10. Use the Fill Handle to copy your formula to the rest of the column

Now let’s get rid of the formula and just keep the results:

11. While the names are still selected, click on the Home tab and
then the Copy button

12. Click in the blank column next to the copied cells and paste

13. At the bottom of the list, you will see the paste icon —click on
the Paste Values icon.

14. Click on one of the names that you just pasted and notice that

only the name appears in the formula bar.

. Alex
Jason

, Mancy
lary

, Mancy
, Mancy
lary

, Joy

, Joy

g, Sam
, Joy
Jason

, Mancy
, Mancy
, Joy
pter

Alex, Suvama, Al
Jason, Davolio, Jason
Nangy, ~-r-=-= koo
Mﬂw F Paste

w5 7 )

Mancy,

Mary, F| |- £H
Joy, Pe Bl
Jov, B alues
Sam, Iis
Joy, PN W |

Jazon,
MNancy, :
Nancy, aﬁ; =3 | |[3l| s
Joy, Peacock, Joy

Peter, King, Peter (Ctrl)

er Paste Options
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3. Sorting

In Excel a List is a collection of similar data stored in a structured manner, rows and columns.

Managing lists of data, such as student records, can be time consuming and difficult. Using an Excel

worksheet to manage the data or list makes the task easier. One of the great features of Excel is the

ability to sort records in various ways and by multiple fields. The fields you use to order your data are

called sort fields or sort keys (Last Name is an example of a sort field). The
quickest way to sort data in Excel is to use the Sort A to Z or Sort Z to A buttons
found in the Editing group on the Home tab. You can also use Custom Sort

feature to sort your data on more than one field.

Exercise 5: Sort a List using a single Sort Field

1. Using the Employee Records worksheet

2. Click any cell in the Last Name column. You do not need to select the entire

Sort & | Find &
Filter = | Select =

8| sortatoz
Z]| sortZton
EI Custom Sart.,
“=| Filter

[x

column. Excel automatically determines the range of the list when you click any cell inside the

list.

3. Click the Sort & Filter button on the Home tab and then click “Sort A to Z” on the sub-menu.

The list is sorted in order by last name.

4. If you selected the wrong column before sorting the list click the

sort.

Undo button to undo the
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4. Advanced Sorting

Exercise 6: Reordering the Columns: sorting by columns @ } EJ %?T
1. Using the Employee Records worksheet, click in cell Al (R etete Fomat | 5 o
2. On the Home Tab, click the bottom of the Insert button and click on i: im: :”TR
Insert Sheet Row I 1::; s,h::t;::smns
3. Number the columns as follows S Insert Sheet
2 1 4 6 3 S
First Name Last Name Position Salary Department Year Hired
4. Select the columns by clicking on “A” in the header row and dragging across all the columns
5. On the Home Tab, click on Sort & Filter > Custom Sort
6. Click on Options and check the Sort left to right option and click OK
7. From the Sort by drop down select Row 1 and click OK
Now that the columns are in the order we want them, you can delete row 1 with the numbers in it.
(‘sort [Fo | &=
“yaddLevel || X peleteLevel |[["sort Options mu (@] My data has headers
Column : Order
: e
[oc J[ conce |
[ o« | [ con
Exercise 7: Sorting a list using more than one field
1. Click any cell in the Employee Records spreadsheet
2. Click on the Sort & Filter button on | Sort
the Home tab and then click 2ucscve || Xpeteiovel | Bacopyiove [ # ][ 8 [ cotons . VM gote hashesdere
Custom Sort on the sub-menu. = Depariment v] SDTOH v] jr::; v
The Sort dialog box is displayed. Trent] [peaten ] (v CINITE ]
3. Under Column, in the Sort by box,
select the first column that you want "3l Addleve
to sort. Choose Department x| [ cone
4. Click on the Add Level button

In the new level — select Position and click OK
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Custom sort options found on the Sort Dialog box — shown above
Under Sort On, select the type of sort. Do one of the following:
e To sort by text, number, or date and time, select Values.
e To sort by format, select Cell Color, Font Color, or Cell Icon.
Under Order, select how you want to sort. Do one of the following:
e For text values, select Ato Z or Z to A.
o For number values, select Smallest to Largest or Largest to Smallest.
« For date or time values, select Oldest to Newest or Newest to Oldest.
e To sort based on a custom list, select Custom L.ist.
To add another column to sort by, click Add Level, and then repeat steps three through five.

5. Filtering
Exercise 8: Filtering a List using AutoFilters

We learned how to sort the data, but what if we want to view data that meets certain criteria, such as
Assistants in the Accounting Department. Using the feature allows you to filter your data so you view
only the records you want.

A B C D E F
1 Last Name = | First Name ~ | Department = | Position * | Year Hired |~ Salary -
2 |Abraham Thomas Information Systems Aszsistant B Laqa e (':""
L ceting 5 ; . .
3_ _-.ﬂeafander ]-Ethztn }Ial’]:.&tl]flc -&mt&tar} iret Name - De ent

4] somatez

2} sortztoa

1. Click any cell in the list to make it active sort by Color
2. Click on the Sort & Filter button on the Home tab and then
click Filter on the sub-menu. Text Filters
3. Filter arrows appear next to each column label in the list. Click search
(Select All)

an arrow next to a column to see a list of filtering criteria for that

Accounting

column. oo e
4. Click the Department list arrow to see the criteria. Click the é:ﬂ:ﬂ::ﬁa:;n rstems
(Select all) check box to unselect all the departments and check
one of the departments to view the chosen data subset.
Click the Position column list arrow and select Secretary ) o

Click the Salary column list arrow Largest to Smallest

o

Try various combinations
To turn off the Filter. Click on the Sort & Filter button on the Home tab and then click Filter

© N o O

on the sub-menu.
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6. Finding Duplicate Records

é Wrap Text Currency - i_i‘l
E EdMergeaCenter~ | § - % o | % ;%5 | |Conditional

Exercise 9: Using Conditional formatting |

Elll Greater Than... —I—:Ig_il Highlight Cells Rules » ||
1. Using the Source Data sheet, click on the column header ] il

.T.
= Top/Bottom Rul b
(E) for the Order ID to select the data g LessThan o] “OREETOMEEE

2. On the Home Tab, click on Conditional Formatting A setween.. EE| patasas »
> Highlight Cells Rules > Duplicate values E,E]I Equal To.. _%J cotor scales )

=

3. From the dialog box, select the cell formatting you would
EQJI Text that Contains... g; Icon Sets 3

like.

1 H H ':% A Date Occurring... Bl NewRdle..
4. You can also choose to highlight Unique Values by == B Clear Rutes )
changing the selection. _g_] Duplicate Values., | 2] Manage Rules.
5. You can now do a Custom Sort and More Rules...

from the “Sort on” drop down select cell color of font color depending on what you chose in step 3.

6. The highlighted records can be deleted - = ———————
or moved. _
Format cells that contain:
Duplicate || values with |Light Red Fil with Dark Red Text [ |
55
Exercise 10: Remove Duplicates Remove
It is best to have a copy of your data before you do this. Duplicates

1. Right click on the Source Data Sheet and then .
click on Move or Copy... Remove Dupicates NN i
2. Click the Create a copy check box and then To delete duplicate values, select one or more columns that contain duplicates.
OK

’ §§ Select Al ] [ 5= Unselect All l My data has headers

3. Click on the original Source Data sheet
4. Click on the Data Tab and then Remove
Duplicates S
5. In the dialog box, select the column or E E;L;Z::mn
columns that contain duplicates ] Order Amount
6. Click ok [ order Date
7. The duplicates have been removed OrderID
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Exercise 11: The IF function
An “If function” used in Excel checks to see if the conditions you specify are True or False. If the
result of the comparison is true, Excel returns one value and if it is false, it returns another.
The basic formula set up looks like this: =IF(logical_test, [value_if true], [value_if false])
In our example we will determine if the sale met the goal of $1500.00 or not.

1. Onthe Sales Data spreadsheet, click in column D and add a column

2. Clickin cell D2 and enter the formula =IF(C2>1500, “Met Goal”, “Keep Going”)
3. Click the Enter key and see if you get the correct answer

4. Use the Fill Handle to copy the formula to the rest of the column.

Learn more about the If Function:

http://office.microsoft.com/en-us/excel-help/the-if-function-what-it-is-and-how-to-use-it-
RZ102425926.aspx?CTT=1

http://blogs.office.com/b/microsoft-excel/archive/2011/03/29/if-and-only-if.aspx



http://office.microsoft.com/en-us/excel-help/the-if-function-what-it-is-and-how-to-use-it-RZ102425926.aspx?CTT=1
http://office.microsoft.com/en-us/excel-help/the-if-function-what-it-is-and-how-to-use-it-RZ102425926.aspx?CTT=1
http://blogs.office.com/b/microsoft-excel/archive/2011/03/29/if-and-only-if.aspx

